Citrix Workspace Requires OS X 10.13 High Sierra or later

Citrix Workspace Requires OS X 10.13 High Sierra or later

Many Mac users have encountered the "Citrix Workspace Requires OS X 10.13 High Sierra or later" message when trying to install the Citrix Workspace App on an Apple device. 

If you receive this error, you need to upgrade your MacOS as it is on a version older than 10.13. The process of installing major operating system updates on these older versions of MacOS is accomplished differently than normal software updates. Please follow these instructions, How to get updates for earlier MacOS Versions, found on the Apple website. There are also specific instructions on How to upgrade to macOS Catalina (10.15), the latest release, also on the Apple website. 

Completing this update process not only allows you access to run Citrix Workspace, but ensures your computer is running with the latest security updates and features from Apple.

 

Staff

Peter Callaghan - Systems Administrator, Network & Infrastructure Services
Robyn Bredvick - Systems Administrator, Network & Infrastructure Services
Rodd Grady - Systems Administrator, Network & Infrastructure Services
  • ITTC 36
  • (319) 273-5555
  • Service Hub